summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:36:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:05 +0200
commitd3b7c6e8218910082b591a970e9e87d3af34df78 (patch)
treef99bf180538dec250a14c11b37bd89a62e33f858 /gnu
parentf1045d22a4926c3023919d7e3250f08b6554c336 (diff)
downloadguix-d3b7c6e8218910082b591a970e9e87d3af34df78.tar.gz
gnu: Add texlive-numerica.
* gnu/packages/tex.scm (texlive-numerica): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dcea01136e..1390d4802b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5162,6 +5162,28 @@ mass and energy data in LaTeX documents.  It uses the PythonTeX package and
 requires @command{pythontex} to be called with the TeX file as the argument.")
     (license license:lppl1.3+)))
 
+(define-public texlive-numerica
+  (package
+    (name "texlive-numerica")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/numerica/" "tex/latex/numerica/")
+             (base32
+              "1dx2nl8p910m8hm7jr9zh6kbpyyxgvz15ya7ppb2d7ilybfg3qqv")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/numerica")
+    (synopsis "Numerically evaluate mathematical expressions in LaTeX form")
+    (description
+     "This package defines a command to wrap around a mathematical expression
+in its LaTeX form and, once values are assigned to variables, numerically
+evaluate it.  The intent is to avoid the need to modify the LaTeX form of the
+expression being evaluated.  For programs with a preview facility like LyX, or
+compile-as-you-go systems, interactive back-of-envelope calculations and
+numerical exploration are possible within the document being worked on.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")