summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorconses <contact@conses.eu>2023-03-17 13:32:48 +0100
committerAndrew Tropin <andrew@trop.in>2023-03-20 09:11:04 +0400
commitd429ff12e5e7e1f0515f4bf5cdda98744cda967e (patch)
treec37cfd51031aed177f073f9abf614eefb03b8fcb /gnu
parent8f5f505d90ec95427670db787179826651f3cc2f (diff)
downloadguix-d429ff12e5e7e1f0515f4bf5cdda98744cda967e.tar.gz
gnu: emacs-eshell-syntax-highlighting: Update to 0.3-0.1ba39a9.
* gnu/packages/emacs-xyz.scm (emacs-eshell-syntax-highlighting): Update to
0.3-0.1ba39a9.

Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a0061da9bb..b1f72ee009 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24624,25 +24624,27 @@ appropriate directory if no @code{eshell} session is active.")
     (license license:gpl3+)))
 
 (define-public emacs-eshell-syntax-highlighting
-  (package
-    (name "emacs-eshell-syntax-highlighting")
-    (version "0.3")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/akreisher/eshell-syntax-highlighting")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1fb9aa85a3hx1rcmv71j6sc3y278452p1y4dabpwy07avb6apd0p"))))
-    (build-system emacs-build-system)
-    (home-page "https://github.com/akreisher/eshell-syntax-highlighting")
-    (synopsis "Add syntax highlighting to Eshell")
-    (description
-     "This package highlights user commands at the Eshell interactive prompt
+  (let ((commit "1ba39a9ffb2298cd716a4314cf3f369028c7bafe")
+        (revision "0"))
+    (package
+      (name "emacs-eshell-syntax-highlighting")
+      (version (git-version "0.3" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/akreisher/eshell-syntax-highlighting")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0w2f5a9cxa365hcc92c24b3kq5dwry3prig57jgnicwmjn5nkqlz"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/akreisher/eshell-syntax-highlighting")
+      (synopsis "Add syntax highlighting to Eshell")
+      (description
+       "This package highlights user commands at the Eshell interactive prompt
 to provide feedback on the validity of commands and syntax.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-eshell-z
   (package