summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-20 03:32:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-20 04:56:33 +0200
commitd4c68d3236b7ce76b6abbd317790fe9956639641 (patch)
tree18c52b242351ac17d794feca07d4e34086c0d58a /gnu
parentbca4b2e7cce1fbb9ec7f9c093a3697c8ddb4cffd (diff)
downloadguix-d4c68d3236b7ce76b6abbd317790fe9956639641.tar.gz
gnu: emacs-m-buffer-el: Return #t from phases.
* gnu/packages/emacs.scm (emacs-m-buffer-el)[arguments]: Substitute
INVOKE for SYSTEM*.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 87159a915a..1829c5900c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8967,10 +8967,10 @@ confused by comments or @code{foo-bar} matching @code{foo}.")
        (modify-phases %standard-phases
          (add-before 'install 'check
            (lambda* (#:key inputs #:allow-other-keys)
-             (zero? (system* "emacs" "--batch" "-L" "."
-                             "-l" "test/m-buffer-test.el"
-                             "-l" "test/m-buffer-at-test.el"
-                             "-f" "ert-run-tests-batch-and-exit")))))))
+             (invoke "emacs" "--batch" "-L" "."
+                     "-l" "test/m-buffer-test.el"
+                     "-l" "test/m-buffer-at-test.el"
+                     "-f" "ert-run-tests-batch-and-exit"))))))
     (build-system emacs-build-system)
     (home-page "https://github.com/phillord/m-buffer-el")
     (synopsis "List oriented buffer operations for Emacs")