summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-01-20 20:59:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-01-20 22:14:37 +0200
commitd6e8a84e2ac0990b6750b93f47d20e58e8488569 (patch)
tree376f22bb28ca5f73aceb061bf014ae40d6f7288c /gnu
parente32d302474ce7c24fae6906198032f4cdbab205c (diff)
downloadguix-d6e8a84e2ac0990b6750b93f47d20e58e8488569.tar.gz
gnu: godot: Fix building on aarch64-linux.
* gnu/packages/game-development.scm (godot)[arguments]: Add a flag when
building for aarch64-linux to build without threads.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 4cd3804d19..0b08b04f51 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1069,6 +1069,10 @@ games.")
     (arguments
      `(#:scons ,scons-python2
        #:scons-flags (list "platform=x11"
+                           ,@(if (string-prefix? "aarch64" (or (%current-target-system)
+                                                               (%current-system)))
+                               `("CCFLAGS=-DNO_THREADS")
+                               '())
                            ;; Avoid using many of the bundled libs.
                            ;; Note: These options can be found in the SConstruct file.
                            "builtin_freetype=no"