summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-17 11:43:12 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:49 +0530
commitda6390144a3eb2bc1143f946df1bcf32e9dfe761 (patch)
tree7b5d23ef3b947580ec14f88f36c102bd71b5259d /gnu
parent75ed6b90e6c4dfd24311a5456aacad6b6d6f51c0 (diff)
downloadguix-da6390144a3eb2bc1143f946df1bcf32e9dfe761.tar.gz
gnu: Add rust-globwalk-0.8.
* gnu/packages/crates-io.scm (rust-globwalk-0.8): New variable.
(rust-globwalk-0.5): Inherit from rust-globwalk-0.8.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm53
1 files changed, 39 insertions, 14 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7d3ba2d91e..dd934c2b24 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9413,33 +9413,58 @@ the process of matching one or more glob patterns against a single candidate
 path simultaneously, and returning all of the globs that matched.")
     (license (list license:expat license:unlicense))))
 
-(define-public rust-globwalk-0.5
+(define-public rust-globwalk-0.8
   (package
     (name "rust-globwalk")
-    (version "0.5.0")
+    (version "0.8.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "globwalk" version))
-        (file-name
-         (string-append name "-" version ".tar.gz"))
-        (sha256
-         (base32
-          "09axyql26s09z60sgi3y3lkin9swy2b5km3b0v6mm84xhlljxyl9"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "globwalk" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0ihld70ngnri1qd8sd61099yfzcl6iqn17rfa102q1bl6ck710hp"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
-       (("rust-ignore" ,rust-ignore-0.4)
+       (("rust-bitflags" ,rust-bitflags-1)
+        ("rust-ignore" ,rust-ignore-0.4)
         ("rust-walkdir" ,rust-walkdir-2))
        #:cargo-development-inputs
-       (("rust-docmatic" ,rust-docmatic-0.1)
+       (("rust-backtrace" ,rust-backtrace-0.3.35)
+        ("rust-docmatic" ,rust-docmatic-0.1)
         ("rust-tempdir" ,rust-tempdir-0.3))))
     (home-page "https://github.com/gilnaa/globwalk")
     (synopsis "Glob-matched recursive file system walking")
-    (description
-     "Glob-matched recursive file system walking.")
+    (description "This package provides glob-matched recursive file system
+walking.  Based on both @code{rust-walkdir} and @code{rust-ignore}, this crate
+inherits many goodies from both, such as limiting search depth and amount of
+open file descriptors.")
     (license license:expat)))
 
+(define-public rust-globwalk-0.5
+  (package
+    (inherit rust-globwalk-0.8)
+    (name "rust-globwalk")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "globwalk" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "09axyql26s09z60sgi3y3lkin9swy2b5km3b0v6mm84xhlljxyl9"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-ignore" ,rust-ignore-0.4)
+        ("rust-walkdir" ,rust-walkdir-2))
+       #:cargo-development-inputs
+       (("rust-docmatic" ,rust-docmatic-0.1)
+        ("rust-tempdir" ,rust-tempdir-0.3))))))
+
 (define-public rust-goblin-0.2
   (package
     (name "rust-goblin")