summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-27 13:24:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-27 13:37:29 +0200
commitdb13eb962f5822647cbc88321031615a39d1ff15 (patch)
tree36e39aa03e365284f219b568dd5654b3ea468706 /gnu
parent17c765e2e1b425c5be06bb1701749656e3d84f4b (diff)
downloadguix-db13eb962f5822647cbc88321031615a39d1ff15.tar.gz
gnu: Add python-strawc.
* gnu/packages/bioinformatics.scm (python-strawc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1775f5a15e..0979a86d8d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14773,6 +14773,28 @@ produced by Oxford Nanopore Technologies’ MinION, GridION or PromethION
 instruments, or Pacific Biosciences RSII or Sequel sequencers.")
    (license license:expat)))
 
+(define-public python-strawc
+  (package
+    (name "python-strawc")
+    (version "0.0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "strawC" version))
+       (sha256
+        (base32
+         "1z1gy8n56lhriy6hdkh9r82ndikndipq2cy2wh8q185qig4rimr6"))))
+    (build-system python-build-system)
+    (inputs
+     `(("curl" ,curl)
+       ("pybind11" ,pybind11)
+       ("zlib" ,zlib)))
+    (home-page "https://github.com/aidenlab/straw")
+    (synopsis "Stream data from .hic files")
+    (description "Straw is library which allows rapid streaming of contact
+data from @file{.hic} files.  This package provides Python bindings.")
+    (license license:expat)))
+
 (define-public r-ascat
   (package
    (name "r-ascat")