summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorErik Edrosa <erik.edrosa@gmail.com>2016-08-04 21:52:18 -0400
committerRicardo Wurmus <rekado@elephly.net>2016-08-05 09:25:41 +0200
commite28e74a518b03de0c5e38f2c3e78ea6fe98a51a0 (patch)
treec641d614a61b6eeb2d6fb693661c736f78e072a9 /gnu
parentf467c352619e88e4261d53107258273e32959655 (diff)
downloadguix-e28e74a518b03de0c5e38f2c3e78ea6fe98a51a0.tar.gz
gnu: Add guile-commonmark
* gnu/packages/guile.scm (guile-commonmark): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index f50605a7fb..f26cc222d4 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1180,4 +1180,29 @@ configuration file, and then reads and evaluates Guile expressions that
 you send to a FIFO file.")
     (license gpl3+)))
 
+(define-public guile-commonmark
+  (package
+    (name "guile-commonmark")
+    (version "0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/OrangeShark/" name
+                                  "/releases/download/v" version
+                                  "/" name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "12cb5fqvvgc87f5xp0ih5az305wnjia89l5jba83d0r2p8bfy0b0"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("guile" ,guile-2.0)))
+    (synopsis "CommonMark parser for Guile")
+    (description
+     "guile-commonmark is a library for parsing CommonMark, a fully specified
+variant of Markdown.  The library is written in Guile Scheme and is designed
+to transform a CommonMark document to SXML.  guile-commonmark tries to closely
+follow the @uref{http://commonmark.org/, CommonMark spec}, the main difference
+is no support for parsing block and inline level HTML.")
+    (home-page "https://github.com/OrangeShark/guile-commonmark")
+    (license lgpl3+)))
+
 ;;; guile.scm ends here