summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAdam Kandur <rndd@tuta.io>2020-11-29 15:23:20 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-11-29 15:33:28 +0100
commite3d5a20605a1541f363518e3e4c5eb9351d1a846 (patch)
tree54ea81cd22f5a23738cadd316b9d00201eef804c /gnu
parent848114144681bc603a795725a53458808e213856 (diff)
downloadguix-e3d5a20605a1541f363518e3e4c5eb9351d1a846.tar.gz
gnu: Add make-hash.
* gnu/packages/lisp-xyz.scm (cl-make-hash, ecl-make-hash, sbcl-make-hash): New
  variables.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 58fb05e03c..2175cf7855 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11549,3 +11549,33 @@ with a complex event filtering system.")
 
 (define-public ecl-deeds
   (sbcl-package->ecl-package sbcl-deeds))
+
+(define-public sbcl-make-hash
+  ;; no tagged branch
+  (let ((revision "1")
+        (commit "ae0909cd8e697520a1085fac6f54ac2b448ebd21"))
+    (package
+      (name "sbcl-make-hash")
+      (version (git-version "1.0.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/genovese/make-hash")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1qa4mcmb3pv44py0j129dd8hjx09c2akpnds53b69151mgwv5qz8"))))
+      (build-system asdf-build-system/sbcl)
+      (home-page "https://github.com/genovese/make-hash")
+      (synopsis "Common Lisp package for flexible hash table creation")
+      (description
+       "This is a Common Lisp package for hash table creation with flexible,
+extensible initializers.")
+      (license license:bsd-3))))
+
+(define-public cl-make-hash
+  (sbcl-package->cl-source-package sbcl-make-hash))
+
+(define-public ecl-make-hash
+  (sbcl-package->ecl-package sbcl-make-hash))