summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2013-02-08 14:39:58 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-08 14:41:25 +0100
commite6e82f629c86c8dc7a732fc886e896f88f4cea2d (patch)
tree801e0bdce81c493294d6b156cfe43379b12209e8 /gnu
parent10879c4ea1dfbe7aadbc44dca2a75cd03b73e5a1 (diff)
downloadguix-e6e82f629c86c8dc7a732fc886e896f88f4cea2d.tar.gz
gnu: Add Hop.
* gnu/packages/scheme.scm (hop): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/scheme.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 4ab6e32d64..d919e4b767 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -27,6 +27,7 @@
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages emacs)
   #:use-module (gnu packages texinfo)
+  #:use-module (gnu packages which)
   #:use-module (ice-9 match))
 
 (define-public mit-scheme
@@ -168,3 +169,37 @@ binary executables.  Bigloo enables full connections between
 Scheme and C programs, between Scheme and Java programs, and
 between Scheme and C# programs.")
     (license gpl2+)))
+
+(define-public hop
+  (package
+    (name "hop")
+    (version "2.4.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "ftp://ftp-sop.inria.fr/indes/fp/Hop/hop-"
+                                 version ".tar.gz"))
+             (sha256
+              (base32
+               "04fhy5jp9lq12fmdqfjzj1w32f7nxc80fagbj7pfci7xh86nm2c5"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases (alist-replace
+                 'configure
+                 (lambda* (#:key inputs outputs #:allow-other-keys)
+                   (let ((out (assoc-ref outputs "out")))
+                     (zero?
+                      (system* "./configure"
+                               (string-append"--prefix=" out)))))
+                 %standard-phases)
+       #:tests? #f))                              ; no test suite
+    (inputs `(("bigloo" ,bigloo)
+              ("which" ,which)))
+    (home-page "http://hop.inria.fr/")
+    (synopsis "A multi-tier programming language for the Web 2.0")
+    (description
+     "HOP is a multi-tier programming language for the Web 2.0 and the
+so-called diffuse Web.  It is designed for programming interactive web
+applications in many fields such as multimedia (web galleries, music players,
+...), ubiquitous and house automation (SmartPhones, personal appliance),
+mashups, office (web agendas, mail clients, ...), etc.")
+    (license gpl2+)))