summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-12-11 21:53:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-12-12 16:14:24 +0200
commite9adcd81b1f709b3770050d21617a04afa53c25c (patch)
treec2be789c434beef2c4ca794b81a47e82debe5350 /gnu
parent2df3d147efcbe040d50f104479856fe9033c1716 (diff)
downloadguix-e9adcd81b1f709b3770050d21617a04afa53c25c.tar.gz
gnu: python-pyqt: Build with more qt modules.
* gnu/packages/qt.scm (python-pyqt)[inputs]: Add qtbase, qtconnectivity,
qtdeclarative, qtlocation, qtmultimedia, qtsensors, qtserialport, qtsvg,
qttools, qtwebchannel, qtwebkit, qtwebsockets, qtx11extras,
qtxmlpatterns.
(python2-pyqt)[inputs]: Same.
(python-pyqt@4)[inputs]: Only use python.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4a8fb6c66d..9988171a4b 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -992,7 +992,21 @@ module provides support functions to the automatically generated code.")
      `(("python-sip" ,python-sip)
        ("qtbase" ,qtbase))) ; for qmake
     (inputs
-     `(("python" ,python-wrapper)))
+     `(("python" ,python-wrapper)
+       ("qtbase" ,qtbase)
+       ("qtconnectivity" ,qtconnectivity)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtlocation" ,qtlocation)
+       ("qtmultimedia" ,qtmultimedia)
+       ("qtsensors" ,qtsensors)
+       ("qtserialport" ,qtserialport)
+       ("qtsvg" ,qtsvg)
+       ("qttools" ,qttools)
+       ("qtwebchannel" ,qtwebchannel)
+       ("qtwebkit" ,qtwebkit)
+       ("qtwebsockets" ,qtwebsockets)
+       ("qtx11extras" ,qtx11extras)
+       ("qtxmlpatterns" ,qtxmlpatterns)))
     (arguments
      `(#:modules ((srfi srfi-1)
                   ,@%gnu-build-system-modules)
@@ -1044,7 +1058,8 @@ contain over 620 classes.")
      `(("python-sip" ,python2-sip)
        ("qtbase" ,qtbase)))
     (inputs
-     `(("python" ,python-2)))))
+     `(("python" ,python-2)
+       ,@(alist-delete "python" (package-inputs python-pyqt))))))
 
 (define-public python-pyqt-5.5
   (package (inherit python-pyqt)
@@ -1120,6 +1135,7 @@ contain over 620 classes.")
     (native-inputs
      `(("python-sip" ,python-sip)
        ("qt" ,qt-4)))
+    (inputs `(("python" ,python-wrapper)))
     (arguments
      `(#:tests? #f ; no check target
        #:modules ((srfi srfi-1)