summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-08 15:01:32 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-17 09:22:49 +0100
commitec2788f077150ad4700b4d970f916dd21418e152 (patch)
treeacf1e46a5b9e8e1fcc30521bb108b239ce444080 /gnu
parentc27da3241ced3ec69586813dae18a123f9634f54 (diff)
downloadguix-ec2788f077150ad4700b4d970f916dd21418e152.tar.gz
gnu: Add texlive-onedown.
* gnu/packages/tex.scm (texlive-onedown): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f178bafcc2..0c4e545edf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3508,6 +3508,50 @@ arrows; record information about document class(es) used; and many more.")
 
 (define-deprecated-package texlive-latex-oberdiek texlive-oberdiek)
 
+(define-public texlive-onedown
+  (let ((template
+         (simple-texlive-package
+          "texlive-onedown"
+          (list "doc/latex/onedown/"
+                "source/latex/onedown/"
+                "tex/latex/onedown/")
+          (base32
+           "04ih7i4v96ggwk4k1mpfx3dzcpi2siqablv93wryg7dk4cks5wkl"))))
+    (package
+      (inherit template)
+      (outputs '("doc" "out"))
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ #t) "latex/onedown")
+         ((#:phases phases)
+          #~(modify-phases #$phases
+              (add-after 'unpack 'chdir
+                (lambda _ (chdir "source/latex/onedown/")))
+              (replace 'copy-files
+                (lambda* (#:key inputs #:allow-other-keys)
+                  (let ((origin (assoc-ref inputs "source"))
+                        (texmf (string-append #$output "/share/texmf-dist"))
+                        (doc (string-append #$output:doc
+                                            "/share/texmf-dist/doc")))
+                    (for-each
+                     (lambda (directory)
+                       (copy-recursively (string-append origin directory)
+                                         (string-append texmf directory)))
+                     '("/source" "/tex/latex/onedown"))
+                    (copy-recursively (string-append origin "/doc")
+                                      doc))))))))
+      (home-page "https://ctan.org/pkg/onedown")
+      (synopsis "Typeset bridge diagrams")
+      (description
+       "This is a comprehensive package to draw all sorts of bridge diagrams,
+including hands, bidding tables, trick tables, and expert quizzes.
+
+It works for all font sizes.  Different fonts for hands, bidding diagrams and
+compass are possible.  It also provides annotations to card and bidding
+diagrams, automated check on consistency of suit and hands, and multilingual
+output of bridge terms.")
+      (license license:lppl1.3+))))
+
 (define-public texlive-latex-rerunfilecheck
   (package
     (inherit (simple-texlive-package