summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2021-04-01 22:49:48 +0800
committer宋文武 <iyzsong@member.fsf.org>2021-04-02 18:31:54 +0800
commitefb895146097fa14a8a38fe6de127f01aaf2a37b (patch)
tree0234484516cd64a107f4cbcc59dd81fac0db37b8 /gnu
parenta890880cf66cd2f625d648898a5c55cf3222a451 (diff)
downloadguix-efb895146097fa14a8a38fe6de127f01aaf2a37b.tar.gz
gnu: Add python-typogrify.
* gnu/packages/python-xyz.scm (python-typogrify): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 68e53c3f92..f2b1551df5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24372,3 +24372,34 @@ entities
 @item Three consecutive dots (... or . . .) into an ellipsis entity
 @end enumerate")
     (license license:bsd-3)))
+
+(define-public python-typogrify
+  (package
+    (name "python-typogrify")
+    (version "2.0.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "typogrify" version))
+              (sha256
+               (base32
+                "0f6b2gnnxjbx1fbmkcscc6qjr4hi78kwm1wx4b766ha3va66dr4b"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "nosetests" "-v"))))))
+    (propagated-inputs
+     `(("python-smartypants" ,python-smartypants)))
+    (native-inputs
+     ;; For tests.
+     `(("python-nose" ,python-nose)))
+    (home-page "https://github.com/mintchaos/typogrify")
+    (synopsis "Filters to transform text into typographically-improved HTML")
+    (description
+     "@code{typogrify} provides a set of custom filters that automatically
+apply various transformations to plain text in order to yield
+typographically-improved HTML.  While often used in conjunction with Jinja and
+Django template systems, the filters can be used in any environment.")
+    (license license:bsd-3)))