summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 17:27:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 19:02:04 +0100
commitf01b17b374b0354b14babe2d323191c729e87804 (patch)
treed864d398db2be7bd1ca98082d743887cbd4ffec4 /gnu
parentf9cd13c95d580c5154201dd21d1610e12feba830 (diff)
downloadguix-f01b17b374b0354b14babe2d323191c729e87804.tar.gz
gnu: chez-web: Use GIT- helpers.
* gnu/packages/chez.scm (chez-web)[version]: Use GIT-VERSION.
[source]: Use GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/chez.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 0145651b70..fcf2a09bdc 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -264,16 +264,15 @@ and 32-bit PowerPC architectures.")
         (revision "1"))
     (package
       (name "chez-web")
-      ;; release 2.0 is different and doesn't work.
-      (version (string-append "2.0-" revision "."
-                              (string-take commit 7)))
+      ;; Release 2.0 is different and doesn't work.
+      (version (git-version "2.0" revision commit))
       (source
        (origin
          (method git-fetch)
          (uri (git-reference
                (url "https://github.com/arcfide/ChezWEB.git")
                (commit commit)))
-         (file-name (string-append name "-" version "-checkout"))
+         (file-name (git-file-name name version))
          (sha256
           (base32 "1dq25qygyncbfq4kwwqqgyyakfqjwhp5q23vrf3bff1p66nyfl3b"))))
       (build-system gnu-build-system)