summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-04 12:54:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-12 11:57:23 +0300
commitf0b9ffcdee75e42ad6c8682886f35c868c433f39 (patch)
tree60b800b3310ab95fe38090a7e07af594d23fa021 /gnu
parentb97712821231e2f846f9c14a906a191125490bb1 (diff)
downloadguix-f0b9ffcdee75e42ad6c8682886f35c868c433f39.tar.gz
gnu: Add rust-doc-comment.
* gnu/packages/crates-io.scm (rust-doc-comment): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3f9bc1ffb7..1d80223068 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -132,6 +132,25 @@ memory but not other memory.  This package provides a discard trait which allows
 for intentionally leaking memory")
     (license license:expat)))
 
+(define-public rust-doc-comment
+  (package
+    (name "rust-doc-comment")
+    (version "0.3.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "doc-comment" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "15rsqxgarfpb1yim9sbp9yfgj7p2dq6v51c6bq1a62paii9ylgcj"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/GuillaumeGomez/doc-comment")
+    (synopsis "Macro to generate doc comments")
+    (description "This package provides a way to generate doc comments
+from macros.")
+    (license license:expat)))
+
 (define-public rust-proc-macro2
   (package
     (name "rust-proc-macro2")