summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2022-06-30 06:32:51 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2022-06-30 06:51:34 -0400
commitf33414564dec9034a61bf545faede6d5ac07a87a (patch)
treeef3e0c415f4f1a824234829074d7406ea03c9dbf /gnu
parent142068c6e4ae00490e8a9d57662fe502d16d737c (diff)
downloadguix-f33414564dec9034a61bf545faede6d5ac07a87a.tar.gz
gnu: Add ruby-sentry.
* gnu/packages/ruby.scm (ruby-sentry): New variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0792b66962..572b2c341f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -12786,3 +12786,27 @@ Dashboard.  It is a Ruby Client library for IRIS / BBS API.")
     (description "Sentry-Core provides a gem that provides a client
 interface for the Sentry error logger.")
     (license license:expat)))
+
+(define-public ruby-sentry
+  (package
+    (name "ruby-sentry")
+    (version "5.3.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "sentry-ruby" version))
+        (sha256
+          (base32 "0by9mvw8rklzpyx59vfija8h3ssfvxvf5nbqxfmygfy6lm1vdngz"))))
+    (build-system ruby-build-system)
+    (arguments
+     ;; No rakefile in gem
+     `(#:tests? #f))
+    (propagated-inputs
+      (list ruby-concurrent
+             ruby-faraday
+             ruby-sentry-core))
+    (home-page "https://sentry.io/for/ruby/")
+    (synopsis "Client interface for the Sentry error logger")
+    (description "Sentry provides a gem that provides a client
+interface for the Sentry error logger.")
+    (license license:expat)))