summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-02-15 23:05:30 +0100
committerJakub Kądziołka <kuba@kadziolka.net>2020-02-16 00:02:09 +0100
commitf3686999a210ba8638859252fc0a7b8afd7b2cc1 (patch)
treee467ea61b0d6e37493243bd32feabd4941bca100 /gnu
parent6d34d3f80b6994d6ba48fa7568dd1fdd86986160 (diff)
downloadguix-f3686999a210ba8638859252fc0a7b8afd7b2cc1.tar.gz
gnu: higan: Don't use auto-generated tarball.
* gnu/packages/emulators.scm (higan)[source]: Don't use autogenerated
  tarball. Fetch from the new location for the repository.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emulators.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 358559aa26..202bbe5c56 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -313,13 +313,13 @@ and a game metadata scraper.")
     (version "106")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://gitlab.com/higan/higan/repository/archive.tar.gz?ref=v"
-             version))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/byuu/higan/")
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0y42pra0dxzlbkyzcp3r8a39pji2bj3p9fl40425f60af2igr4rw"))
+        (base32 "1mxivf8124vz4hl0b0xa1yqv0z9m3i12v9psmbpqkprrbq0wbgn1"))
        (patches (search-patches "higan-remove-march-native-flag.patch"))))
     (build-system gnu-build-system)
     (native-inputs