summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-01-01 09:30:23 +0800
committer宋文武 <iyzsong@gmail.com>2015-01-02 11:20:13 +0800
commitf4e9727786e69533c4b255d5558a992a475ad3b4 (patch)
tree279a76ac7f0f9743e02c19361381b80d3b551937 /gnu
parent27ef7f45422ddc068c20c25ba0e43f44eaafbf78 (diff)
downloadguix-f4e9727786e69533c4b255d5558a992a475ad3b4.tar.gz
gnu: icon-naming-utils: Wrap with PERL5LIB to find XML::Simple.
Fixes <http://bugs.gnu.org/19367>.

* gnu/packages/gnome.scm (icon-naming-utils)[arguments]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1ff9e85957..a2ef712220 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -312,6 +312,18 @@ for settings shared by various components of the GNOME desktop.")
     (inputs
      `(("perl" ,perl)
        ("perl-xml-simple" ,perl-xml-simple)))
+    (arguments
+     '(#:phases
+       (alist-cons-after
+        'install 'set-load-paths
+        ;; Tell 'icon-name-mapping' where XML::Simple is.
+        (lambda* (#:key outputs #:allow-other-keys)
+          (let* ((out  (assoc-ref outputs "out"))
+                 (prog (string-append out "/libexec/icon-name-mapping")))
+            (wrap-program
+             prog
+             `("PERL5LIB" = ,(list (getenv "PERL5LIB"))))))
+        %standard-phases)))
     (home-page "http://tango.freedesktop.org/Standard_Icon_Naming_Specification")
     (synopsis
      "Utility to implement the Freedesktop Icon Naming Specification")