summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2018-12-01 11:13:25 -0600
committerEric Bavier <bavier@member.fsf.org>2018-12-01 11:14:32 -0600
commitf88c0ab831e2b14632557373349bfc8e67cb5858 (patch)
tree5ab13eb1ac3a389ee0343559722ad9e4c8c88822 /gnu
parentfb0b645658041c3061d2f70dc1a11a100f569217 (diff)
downloadguix-f88c0ab831e2b14632557373349bfc8e67cb5858.tar.gz
tuxpaint: Fix .desktop and icon installation.
* gnu/packages/games.scm (tuxpaint)[arguments]: 'GNOME_PREFIX' ->
'KDE_PREFIX'.  Add 'no-sys-cache phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 36eaa6c063..7f84e447bb 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3299,12 +3299,18 @@ safety of the Chromium vessel.")
                       "GPERF=gperf" "CC=gcc"
                       "SDL_PCNAME=sdl SDL_image SDL_mixer SDL_ttf"
                       ,(string-append "PREFIX=" %output)
-                      "GNOME_PREFIX=$(PREFIX)"
+                      "KDE_PREFIX=$(PREFIX)/share/applications"
+                      "KDE_ICON_PREFIX=$(PREFIX)/share/icons/"
                       "COMPLETIONDIR=$(PREFIX)/etc/bash_completion.d")
        #:parallel-build? #f             ;fails on some systems
        #:tests? #f                      ;No tests
        #:phases (modify-phases %standard-phases
                   (delete 'configure)   ;no configure phase
+                  (add-before 'install 'no-sys-cache
+                    (lambda _           ;do not rebuild system conf cache
+                      (substitute* "Makefile"
+                        (("kbuildsycoca4") ""))
+                      #t))
                   (add-after 'install 'fix-import
                     (lambda* (#:key inputs outputs #:allow-other-keys)
                       (let* ((out (assoc-ref outputs "out"))