summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-15 17:26:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 19:02:04 +0100
commitf9cd13c95d580c5154201dd21d1610e12feba830 (patch)
tree12d31f39cf332bfeb20f76983c40469ad3789aa8 /gnu
parentbd86f7dbdf366c52214cda824246b2e642d32a96 (diff)
downloadguix-f9cd13c95d580c5154201dd21d1610e12feba830.tar.gz
gnu: chez-srfi: Don't use unstable tarball.
* gnu/packages/chez.scm (chez-srfi)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/chez.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index cbbca34c1a..0145651b70 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -237,13 +237,13 @@ and 32-bit PowerPC architectures.")
     (version "1.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/fedeinthemix/chez-srfi/archive"
-             "/v" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/fedeinthemix/chez-srfi.git")
+             (commit (string-append "v" version))))
        (sha256
-        (base32 "17i4wly7bcr5kb5hf04ljpbvv4r5hsr9xsmw650fj43z9jr303gs"))
-       (file-name (string-append name "-" version ".tar.gz"))))
+        (base32 "1vgn984mj2q4w6r2q66h7qklp2hrh85wwh4k9yisga5fi0ps7myf"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (native-inputs
      `(("chez-scheme" ,chez-scheme)))