summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-10 21:34:10 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-10 21:43:14 +0200
commitfb6c2fa82e1499e6cba8ac860bc0f4902d1ff9ea (patch)
tree995eed16aa8038276f689b85670b8f67ee1f0406 /gnu
parentb49632e79383ea91eaacfaf6fca388942f8e2cde (diff)
downloadguix-fb6c2fa82e1499e6cba8ac860bc0f4902d1ff9ea.tar.gz
gnu: linux-libre-headers: Support cross-compilation.
* gnu/packages/linux.scm (linux-libre-headers):
  When (%current-target-system) is true, pass it as the argument to
  'build-phase'.  This fixes cross-compilation.
  Reported by Mark H. Weaver <mhw@netris.org>.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b53c02e1dc..469ccc552c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -102,7 +102,8 @@
                   (guix build utils)
                   (srfi srfi-1))
        #:phases (alist-replace
-                 'build ,(build-phase (%current-system))
+                 'build ,(build-phase (or (%current-target-system)
+                                          (%current-system)))
                  (alist-replace
                   'install ,install-phase
                   (alist-delete 'configure %standard-phases)))