summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2016-10-02 22:41:29 -0400
committer宋文武 <iyzsong@gmail.com>2016-10-06 20:33:55 +0800
commitfb7dc6d6473920495d740e28901c4ce534f10bd8 (patch)
tree20dc784169e974583de2030e31853a9c2a28c042 /gnu
parent8d0489aeb6800f9e430262a42a17cc0ff3ed434f (diff)
downloadguix-fb7dc6d6473920495d740e28901c4ce534f10bd8.tar.gz
gnu: ecl: Honour XDG_DATA_DIRS/ecl-bundle-systems.
* gnu/packages/lisp.scm (ecl)[source]: Add snippet.
[native-search-paths]: Add XDG_DATA_DIRS.

Signed-off-by: 宋文武 <iyzsong@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 73ebc38950..073ddd46f9 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -123,7 +123,12 @@ interface to the Tk widget system.")
              "https://common-lisp.net/project/ecl/static/files/release/"
              name "-" version ".tgz"))
        (sha256
-        (base32 "16ab8qs3awvdxy8xs8jy82v8r04x4wr70l9l2j45vgag18d2nj1d"))))
+        (base32 "16ab8qs3awvdxy8xs8jy82v8r04x4wr70l9l2j45vgag18d2nj1d"))
+       (modules '((guix build utils)))
+       (snippet
+        ;; Add ecl-bundle-systems to 'default-system-source-registry'.
+        `(substitute* "contrib/asdf/asdf.lisp"
+           ,@(asdf-substitutions name)))))
     (build-system gnu-build-system)
     ;; src/configure uses 'which' to confirm the existence of 'gzip'.
     (native-inputs `(("which" ,which)))
@@ -164,6 +169,10 @@ interface to the Tk widget system.")
                  `("LIBRARY_PATH" suffix ,library-directories)
                  `("LD_LIBRARY_PATH" suffix ,library-directories)))))
          (add-after 'wrap 'check (assoc-ref %standard-phases 'check)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "XDG_DATA_DIRS")
+            (files '("share")))))
     (home-page "http://ecls.sourceforge.net/")
     (synopsis "Embeddable Common Lisp")
     (description "ECL is an implementation of the Common Lisp language as