summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-15 17:46:55 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-15 17:46:55 +0200
commitff46707281096b41818737c14933b3cf829abf49 (patch)
tree08aeff931b3032582f75175f378f819e98dc1c55 /gnu
parentdc8d69760960d6c1467d73658b306e31ccac3332 (diff)
downloadguix-ff46707281096b41818737c14933b3cf829abf49.tar.gz
gnu: Add libdbusmenu-qt.
*  gnu/packages/kde.scm (libdbusmenu-qt): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index bb2a7ec997..0a71329c99 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -17,7 +17,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages kde)
-  #:use-module ((guix licenses) #:select (bsd-2 lgpl2.1 lgpl2.1+))
+  #:use-module ((guix licenses) #:select (bsd-2 lgpl2.0+ lgpl2.1 lgpl2.1+))
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system cmake)
@@ -102,3 +102,31 @@ objects and vice versa.  JSON arrays are mapped to QVariantList instances,
 while JSON objects are mapped to QVariantMap.")
     (license lgpl2.1+)))
 
+(define-public libdbusmenu-qt
+  (package
+    (name "libdbusmenu-qt")
+    (version "0.9.2")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "https://launchpad.net/" name "/trunk/"
+                                 version "/+download/"
+                                 name "-" version ".tar.bz2"))
+             (sha256
+              (base32
+               "1v0ri5g9xw2z64ik0kx0ra01v8rpjn2kxprrxppkls1wvav1qv5f"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("qjson", qjson)
+       ("qt" ,qt-4)))
+    (arguments
+     `(#:tests? #f ; no check target
+       #:configure-flags
+        '("-DWITH_DOC=OFF"))) ; FIXME: drop once input doxygen is available
+    (home-page "https://launchpad.net/libdbusmenu-qt/")
+    (synopsis "Qt implementation of the DBusMenu protocol")
+    (description "The library provides a Qt implementation of the DBusMenu
+protocol.  The DBusMenu protocol makes it possible for applications to export
+and import their menus over DBus.")
+    (license lgpl2.0+)))