summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-16 16:39:13 +0200
committerMarius Bakke <marius@gnu.org>2022-09-16 18:42:20 +0200
commitfff525acca82bfbf2449686b5bf4977f29386788 (patch)
tree41e38188ceb2ce5641f53dbfc47366143b936e0b /gnu
parent937215d562f65cd24c0113ebc3663e93fec0f595 (diff)
downloadguix-fff525acca82bfbf2449686b5bf4977f29386788.tar.gz
gnu: Add python-openstep-plist.
* gnu/packages/python-xyz.scm (python-openstep-plist): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index de3fc1791d..c140044dfc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11592,6 +11592,40 @@ reading and writing MessagePack data.")
 and MAC network addresses.")
     (license license:bsd-3)))
 
+(define-public python-openstep-plist
+ (package
+  (name "python-openstep-plist")
+  (version "0.3.0")
+  (home-page "https://github.com/fonttools/openstep-plist")
+  (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url home-page)
+                  (commit (string-append "v" version))))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "1rxjgzh0p069ncsr2986rn32vhdqyq35irbqg2559jh18456mkca"))))
+  (build-system python-build-system)
+  (arguments
+   (list #:phases
+         #~(modify-phases %standard-phases
+             (add-after 'unpack 'pretend-version
+               (lambda _
+                 (setenv "SETUPTOOLS_SCM_PRETEND_VERSION"
+                         #$(package-version this-package))))
+             (replace 'check
+               (lambda* (#:key tests? #:allow-other-keys)
+                 (when tests?
+                   (invoke "pytest" "-vv")))))))
+  (native-inputs
+   (list python-cython python-pytest python-setuptools-scm))
+  (synopsis "OpenStep plist parser and writer")
+  (description
+   "This package provides a parser for the \"old style\" OpenStep property
+list format (also known as ASCII plist), written in Cython.")
+  (license license:expat)))
+
 (define-public python-wrapt
   (package
     (name "python-wrapt")