summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-05-12 23:05:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-15 00:03:25 +0200
commit02a08325533123e9bd9b5071f32a3c93bdd341c8 (patch)
tree993b320966515595eacad49555798bb96637dde3 /gnu
parentbb94429cb776dc658361e9c26f999c9648d0bd86 (diff)
downloadguix-02a08325533123e9bd9b5071f32a3c93bdd341c8.tar.gz
gnu: Add emacs-tshell.
* gnu/packages/emacs-xyz.scm (emacs-tshell): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8d8b3f9ea3..8e3d832a72 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27238,6 +27238,33 @@ easily.  Four pre-set options are: @samp{shell}, @samp{terminal},
 you use some other configuration.")
       (license license:gpl3+))))
 
+(define-public emacs-tshell
+  ;; XXX: Upstream has no tagged release.  Version is extracted from keyword
+  ;; in main file.
+  (let ((commit "47ef3a6c537b06eb422d9a124e1c44062223e323")
+        (revision "0"))
+    (package
+      (name "emacs-tshell")
+      (version (git-version "0.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/TatriX/tshell")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0yv38bqdp6b614lbj4v408vv5mlic3vs1v7266xrfxm1cm903apj"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-transient" ,emacs-transient)))
+      (home-page "https://github.com/TatriX/tshell")
+      (synopsis "Experimental buffer-oriented Emacs shell")
+      (description
+       "Tshell is an experimental buffer-oriented shell.  It supports shell
+and Emacs lisp commands.")
+      (license license:gpl3+))))
+
 (define-public emacs-extmap
   (package
     (name "emacs-extmap")