summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-20 09:49:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-20 10:06:36 +0200
commit04ed3821cc7b15a22946ca972525626b41d71763 (patch)
treee7facbce81fe215327b358c35e3f6d3c5b7afe60 /gnu
parent1f50f11aefe0fb1937cb15d4e327e0ffd94071d7 (diff)
downloadguix-04ed3821cc7b15a22946ca972525626b41d71763.tar.gz
gnu: Add python-test-utils.
* gnu/packages/python-check.scm (python-test-utils): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index b86f75dc1b..d788935caa 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2166,6 +2166,24 @@ Python objects.  It tries to use the objects available in the standard
 @code{unittest} module.")
     (license license:expat)))
 
+(define-public python-test-utils
+  (package
+    (name "python-test-utils")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "test-utils" version))
+       (sha256
+        (base32 "0cs0gyihnkj8ya4yg3ld3ly73mpxrkn2gq9acamclhqvhxsv7zd6"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/Kami/python-test-utils/")
+    (synopsis "Utilities for functional and integration tests")
+    (description
+     "This package provides a collection of utility functions and classes
+which make writing and running functional and integration tests easier.")
+    (license license:asl2.0)))
+
 (define-public python-sybil
   (package
     (name "python-sybil")