summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-25 11:56:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-25 14:01:32 +0300
commit2de88bcd7a67305e23929fd73deca1b5df22aa9e (patch)
tree8c4e7a51be0f7ae8489b0c27519cd5035361e18f /gnu
parent988eb73d5b8c84f413382b8a80b4d4d72eff6747 (diff)
downloadguix-2de88bcd7a67305e23929fd73deca1b5df22aa9e.tar.gz
gnu: python-cython: Update to 0.29.24.
* gnu/packages/python-xyz.scm (python-cython): Update to 0.29.24.
[arguments]: Adjust custom 'check phase to skip one test. Remove
trailing #t from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 771c373090..9aa2dc8d32 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5161,13 +5161,13 @@ provides additional functionality on the produced Mallard documents.")
 (define-public python-cython
   (package
     (name "python-cython")
-    (version "0.29.22")
+    (version "0.29.24")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Cython" version))
        (sha256
-        (base32 "01jl3544qwsi8lp6anbl55566xqkjd53x452i7m6gnfilv3q6syz"))))
+        (base32 "0hw4gs18rh4slij1fg252argxhraypld9apbqbl60230qc3lvw6d"))))
     (build-system python-build-system)
     ;; we need the full python package and not just the python-wrapper
     ;; because we need libpython3.3m.so
@@ -5178,9 +5178,9 @@ provides additional functionality on the produced Mallard documents.")
        (modify-phases %standard-phases
          (add-before 'check 'set-HOME
            ;; some tests require access to "$HOME/.cython"
-           (lambda _ (setenv "HOME" "/tmp") #t))
+           (lambda _ (setenv "HOME" "/tmp")))
          (replace 'check
-           (lambda _
+           (lambda* (#:key tests? #:allow-other-keys)
              ;; Disable compiler optimizations to greatly reduce the running
              ;; time of the test suite.
              (setenv "CFLAGS" "-O0")
@@ -5192,7 +5192,9 @@ provides additional functionality on the produced Mallard documents.")
                      ;; <https://github.com/cython/cython/issues/2807>.
                      ,@(if (not (target-64bit?))
                            '("-x" "run.parallel")
-                           '())))))))
+                           '())
+                     ;; This test fails when running on 24 cores.
+                     "-x" "cpp_stl_conversion"))))))
     (home-page "https://cython.org/")
     (synopsis "C extensions for Python")
     (description "Cython is an optimising static compiler for both the Python