summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:36:25 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:34 -0400
commit312295d881031fa02b43930620bf833268b7eea3 (patch)
treed99908754e7a94c613e0a0e3156cde3eed85b4a8 /gnu
parentcfc02804fc5808647630c2fd75402887923168c8 (diff)
downloadguix-312295d881031fa02b43930620bf833268b7eea3.tar.gz
gnu: Remove patches.
* gnu/packages/patchutils.scm (patches): Delete variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patchutils.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index 856413d83c..fdbcb8e1e1 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -186,35 +186,6 @@ refreshed, and more.")
 'syntax highlighting' for various patch formats.")
     (license gpl2+)))
 
-(define-public patches
-  (let ((commit "ef1b8a7d954b82ed4af3a08fd63d2085d19090ef"))
-    (package
-      (name "patches")
-      (home-page "https://github.com/stefanha/patches")
-      (version (string-append "0.0-1." (string-take commit 7)))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url home-page)
-                      (commit commit)))
-                (sha256
-                 (base32
-                  "11rdmhv0l1s8nqb20ywmw2zqizczch2p62qf9apyx5wqgxlnjshk"))
-                (file-name (string-append name "-"version "-checkout"))))
-      (build-system python-build-system)
-      (inputs (list python2-notmuch))
-      (arguments
-       `(#:tests? #f                             ;no "test" target
-         #:python ,python-2))                    ;not compatible with Python 3
-      (synopsis "Patch tracking tool")
-      (description
-       "@code{Patches} is a patch-tracking tool initially written for the QEMU
-project.  It provides commands that build a database of patches from a mailing
-list, and commands that can search that database.  It allows users to track
-the status of a patch, apply patches, and search for patches---all that from
-the command-line or from Emacs via its Notmuch integration.")
-      (license gpl2+))))
-
 (define-public vbindiff
   (package
     (name "vbindiff")