summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristine Lemmer-Webber <cwebber@dustycloud.org>2023-04-26 14:27:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-26 14:49:07 +0200
commit3856ca96fca9e573b15167eee11a3d1d0d7543d0 (patch)
tree50d12bd3f4976c524ba946c6d8c66c70f334840d /gnu
parentc3509c2148ee74b66a7e4338c626cd3b582ab51c (diff)
downloadguix-3856ca96fca9e573b15167eee11a3d1d0d7543d0.tar.gz
gnu: Add emacs-lojban.
* gnu/packages/emacs-xyz.scm (emacs-lojban): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7c8af093fc..7b19eed33e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35141,6 +35141,32 @@ the TypeScript implementation.")
 service.")
       (license license:expat))))
 
+(define-public emacs-lojban
+  (let ((commit "d80bccd72cd46a3a6eeb57b765ec54081da55431")) ;initial commit
+    (package
+      (name "emacs-lojban")
+      ;; XXX: Repository contains two Elisp files: "lojban.el" and
+      ;; "lojban-mode.el". The former has version set to 0.23 and the latter
+      ;; to 0.7. Choosing the higher one.
+      (version "0.23")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/rev22/lojban-mode.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1jm47kl6xqyymwy3dw6zgngf58xwm3mz0q2iiy9br6z66b3r5l5z"))))
+      (build-system emacs-build-system)
+      (home-page "https://www.emacswiki.org/emacs/LojbanMode")
+      (synopsis "Emacs utilities for operating on Lojban text")
+      (description
+       "Lojban is an Emacs library of functions, variables, regexps and
+interactive commands for handling Lojban text.")
+      (license license:gpl2+))))
+
 (define-public emacs-xonsh-mode
   ;; There is no tagged release yet.
   (let ((commit "7fa581524533a9b6b770426e4445e571a69e469d")