summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-29 00:04:21 +0000
committerLeo Famulari <leo@famulari.name>2021-11-28 21:51:12 -0500
commit3d54f2415672aed64661bed84a043a7f0cee13dd (patch)
tree0aab4884f0ebd584e1f65b090aee07f0c181093b /gnu
parent91ed05114969422392f2308295670a1275abbbe9 (diff)
downloadguix-3d54f2415672aed64661bed84a043a7f0cee13dd.tar.gz
gnu: darktable: Build with OpenEXR 3.
* gnu/packages/photo.scm (darktable)[arguments]<#:phases>: Rename
'set-LDFLAGS-and-CPATH to 'set-LDFLAGS. Don't set CPATH.
[inputs]: Remove ilmbase. Add imath. Replace openexr-2 with openexr.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/photo.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 8a07f32f3c..34d9cc3dd0 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -504,18 +504,12 @@ photographic equipment.")
              (substitute* "CMakeLists.txt"
                (("\\$\\{LLVM_INSTALL_PREFIX\\}")
                 (assoc-ref %build-inputs "clang")))))
-         (add-before 'configure 'set-LDFLAGS-and-CPATH
-           (lambda* (#:key inputs outputs #:allow-other-keys)
+         (add-before 'configure 'set-LDFLAGS
+           (lambda* (#:key outputs #:allow-other-keys)
              (setenv "LDFLAGS"
                      (string-append
                       "-Wl,-rpath="
-                      (assoc-ref outputs "out") "/lib/darktable"))
-
-             ;; Ensure the OpenEXR headers are found.
-             (setenv "CPATH"
-                     (string-append
-                      (search-input-directory inputs "include/OpenEXR")
-                      ":" (or (getenv "CPATH") "")))))
+                      (assoc-ref outputs "out") "/lib/darktable"))))
          (add-after 'install 'wrap-program
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (wrap-program (string-append (assoc-ref outputs "out")
@@ -550,7 +544,7 @@ photographic equipment.")
        ("graphicsmagick" ,graphicsmagick)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gtk+" ,gtk+)
-       ("ilmbase" ,ilmbase)
+       ("imath" ,imath)
        ("iso-codes" ,iso-codes) ;optional, for language names in the preferences
        ("json-glib" ,json-glib)
        ("lcms" ,lcms)
@@ -569,7 +563,7 @@ photographic equipment.")
        ("libxslt" ,libxslt)
        ("lua" ,lua) ;optional, for plugins
        ("opencl-icd-loader" ,opencl-icd-loader) ;optional, for OpenCL support
-       ("openexr" ,openexr-2) ;optional, for EXR import/export
+       ("openexr" ,openexr) ;optional, for EXR import/export
        ("openjpeg" ,openjpeg) ;optional, for JPEG2000 export
        ("osm-gps-map" ,osm-gps-map) ;optional, for geotagging view
        ("pugixml" ,pugixml)