summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-25 18:33:20 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-25 18:33:20 +0200
commit42298953bad9f56379810d39295f1f79cabad4be (patch)
treed5f675476e3a58394bbe176545569a506f4a518a /gnu
parentd9e7d9c40843f508275daeddf90cb4b307db2fbe (diff)
downloadguix-42298953bad9f56379810d39295f1f79cabad4be.tar.gz
gnu: uhttpmock: Fix tests.
* gnu/packages/web.scm (uhttpmock)[arguments]: Add 'set-home-for-tests' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 786804be02..711bbd615b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -52,6 +52,7 @@
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5089,6 +5090,12 @@ fast and flexible way of exploring HTML from the terminal.")
        ("pkg-config" ,pkg-config)))
     (inputs
      `(("libsoup" ,libsoup)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'set-home-for-tests
+           (lambda _
+             (setenv "HOME" "/tmp"))))))
     (home-page "https://gitlab.com/groups/uhttpmock")
     (synopsis "Library for mocking web service APIs which use HTTP or HTTPS")
     (description