summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-01 21:33:48 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-12-01 21:37:12 -0500
commit4781f0458de7419606b71bdf0fe56bca83ace910 (patch)
tree5f607bb27afaffe7a1b3a49c703164c64ebf0fcd /gnu
parent2775bb95c7e4ecfaf81af579e8003dddedab6960 (diff)
downloadguix-4781f0458de7419606b71bdf0fe56bca83ace910.tar.gz
Revert "gnu: linux-libre: Move info manual to doc output."
This reverts commit 748ec628826cea3faa3679074d87fae9bc810080.  It broke the
linux-libre-module-builder like so:

   builder for
   `/gnu/store/293jxydym9z7ck7afmrjqhiw3xpfs4i1-linux-libre-module-builder-6.0.10.drv'
   failed to produce output path
   `/gnu/store/ghmp1q5w6r1s9364rz53jd42152wgz2v-linux-libre-module-builder-6.0.10-doc'

for reasons difficult to understand.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1bff1ccaee..8c417fb600 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -836,7 +836,6 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
     (version version)
     (source source)
     (supported-systems supported-systems)
-    (outputs `("out" ,@(if build-doc? '("doc") '())))
     (build-system gnu-build-system)
     (arguments
      (list
@@ -863,16 +862,10 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
                         (invoke "make" "infodocs")))
                     (add-after 'build-doc 'install-doc
                       (lambda _
-                        (let* ((info-dir (string-append #$output:doc
-                                                        "/share/info"))
-                               (info (string-append
-                                      info-dir "/TheLinuxKernel.info.gz")))
-                          (with-directory-excursion "Documentation/output"
-                            (invoke "make" "-C" "texinfo" "install-info"
-                                    (string-append "infodir=" info-dir)))
-                          ;; Create a symlink, for convenience.
-                          (symlink info (string-append info-dir
-                                                       "/linux.info.gz"))))))
+                        (with-directory-excursion "Documentation/output"
+                          (invoke "make" "-C" "texinfo" "install-info"
+                                  (string-append "infodir=" #$output
+                                                 "/share/info"))))))
                  #~())
           (add-before 'configure 'set-environment
             (lambda* (#:key target #:allow-other-keys)