summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-12 12:17:36 +0200
committerMarius Bakke <marius@gnu.org>2022-09-09 17:03:56 +0200
commit66b6d6a9301a70540c434f3fbd2567ff28bedcff (patch)
treeb715aa9da639fa119b99ca1b6121aacff34ed641 /gnu
parent6c03dce10d00af23657da89472c38fce8e9a41a5 (diff)
downloadguix-66b6d6a9301a70540c434f3fbd2567ff28bedcff.tar.gz
gnu: python-exceptiongroup: Disable tests.
* gnu/packages/python-xyz.scm (python-exceptiongroup)[arguments]: Add #:tests?.
[native-inputs]: Remove PYTHON-PYTEST.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 235a27fde9..da025f6692 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3088,6 +3088,7 @@ and is not compatible with JSON.")
     (build-system python-build-system)
     (arguments
      (list
+      #:tests? #f                       ;TODO: Circular dependency on pytest
       #:phases
       #~(modify-phases %standard-phases
           ;; XXX: PEP 517 manual build/install procedures copied from
@@ -3107,7 +3108,7 @@ and is not compatible with JSON.")
             (lambda* (#:key tests? #:allow-other-keys)
               (when tests?
                 (invoke "pytest" "-vv" "tests")))))))
-    (native-inputs (list python-flit-scm python-pypa-build python-pytest))
+    (native-inputs (list python-flit-scm python-pypa-build))
     (home-page "https://github.com/agronholm/exceptiongroup")
     (synopsis "PEP 654 backport from Python 3.11")
     (description "This is a backport of the @code{BaseExceptionGroup} and