summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-20 14:55:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-20 17:02:02 +0300
commit6aa648f8d6f8bc59781beacd0a84f2c640f6e005 (patch)
tree3ae12c0173c076afd0c2bc92ae408f753b714b3f /gnu
parent08dff365f620642381c686cef23d8a53e3fc10a4 (diff)
downloadguix-6aa648f8d6f8bc59781beacd0a84f2c640f6e005.tar.gz
gnu: diffoscope: Only build with fpc on supported architectures.
* gnu/packages/diffoscope.scm (diffoscope)[native-inputs]: Only add fpc
on x86_64-linux or i686-linux.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/diffoscope.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 4b5f7a1030..2dc3cfad0f 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2019 Vagrant Cascadian <vagrant@reproducible-builds.org>
+;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -176,10 +177,15 @@
 
              ;; XXX: Must be the same version as python-magic uses;
              ;; remove when 'file' is updated.
-             file-next
+             file-next)
 
-             fpc
-             gettext-minimal
+       (match (%current-system)
+              ;; fpc is only available on x86 currently.
+              ((or "x86_64-linux" "i686-linux")
+               (list fpc))
+              (_ '()))
+
+       (list gettext-minimal
              ghostscript
              `(,giflib "bin")
              gnumeric