summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-11-28 23:27:18 +0000
committerLudovic Courtès <ludo@gnu.org>2022-12-05 22:22:20 +0100
commit7f380a2e26f59ef99b4a02d65c67192a9ad24cb5 (patch)
tree0e2790cf0b876760e5b991a6d3295bcc889cb590 /gnu
parent6468d9c131921c82a4389f0c1670807fb635f4f2 (diff)
downloadguix-7f380a2e26f59ef99b4a02d65c67192a9ad24cb5.tar.gz
gnu: python-sgp4: Move to astronomy.
* gnu/packages/astronomy.scm: (python-sgp4): Move here from python-science.scm.
  [description]: Expand description, annotate acronyms, add link to CelesTrak.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm29
-rw-r--r--gnu/packages/python-science.scm20
2 files changed, 29 insertions, 20 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 759ccbec9e..d4c886e82b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1464,6 +1464,35 @@ re-gridding of images from one world coordinate system to another e.g.
 changing the pixel resolution, orientation, coordinate system.")
     (license license:bsd-3)))
 
+(define-public python-sgp4
+  (package
+    (name "python-sgp4")
+    (version "2.21")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "sgp4" version))
+       (sha256
+        (base32 "1vzcrlrlzmhbycdz16m8v241l8zx49vsy81wcd0yjxs80isvhyb1"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-numpy))
+    (home-page "https://github.com/brandon-rhodes/python-sgp4")
+    (synopsis "Track earth satellite TLE orbits using SGP4")
+    (description
+     "This package provides a Python implementation for computations of the
+position and velocity of an earth-orbiting satellite, given the satellite’s
+@acronym{TLE, Two-line element set} orbital elements from a source like
+@url{CelesTrak, https://celestrak.org/}.
+
+It implements the most recent version of @acronym{SGP4, Simplified General
+Perturbation models}, and is regularly run against the SGP4 test suite to make
+sure that its satellite position predictions agree to within 0.1 mm with the
+predictions of the standard distribution of the algorithm.  This error is far
+less than the 1–3 km/day by which satellites themselves deviate from the ideal
+orbits described in TLE files.")
+    (license license:expat)))
+
 (define-public python-sunpy
   (package
     (name "python-sunpy")
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index ef4d93500a..dab044d9f7 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -290,26 +290,6 @@ logic, also known as grey logic.")
 genetic variation data.")
     (license license:expat)))
 
-(define-public python-sgp4
-  (package
-    (name "python-sgp4")
-    (version "2.21")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "sgp4" version))
-       (sha256
-        (base32 "1vzcrlrlzmhbycdz16m8v241l8zx49vsy81wcd0yjxs80isvhyb1"))))
-    (build-system python-build-system)
-    (propagated-inputs
-     (list python-numpy))
-    (home-page "https://github.com/brandon-rhodes/python-sgp4")
-    (synopsis "Track earth satellite TLE orbits using SGP4")
-    (description
-     "This package provides a Python implementation of the most recent version
-of the SGP4 satellite tracking algorithm.")
-    (license license:expat)))
-
 (define-public python-trimesh
   (package
     (name "python-trimesh")