summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-10-03 17:33:54 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:16 +0100
commit7fa0e39acb1819a2c88158c73a9622288ac5acda (patch)
tree280a3efd000d7f987a375e66538fb0090fd176d7 /gnu
parentea576461f29f10fad7343e964c583aab3b2d6cea (diff)
downloadguix-7fa0e39acb1819a2c88158c73a9622288ac5acda.tar.gz
gnu: Add kosmindoormap.
* gnu/packages/kde.scm (kosmindoormap): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 2558530203..1c1c371fb8 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -802,6 +802,32 @@ cards.")
 opening hours expressions.")
     (license license:lgpl2.0+)))
 
+(define-public kosmindoormap
+  (package
+    (name "kosmindoormap")
+    (version "22.08.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/release-service/"
+                                  version "/src/" name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "042axwxa1497snr8f0m6a61gl9ypdkvllnhnlw4h5ffah7yl5n3s"))))
+    (build-system cmake-build-system)
+    (native-inputs (list bison extra-cmake-modules flex))
+    (inputs (list ki18n
+                  kopeninghours
+                  kpublictransport
+                  qtbase-5
+                  qtdeclarative-5
+                  zlib))
+    (home-page "https://invent.kde.org/libraries/kosmindoormap")
+    (synopsis "Indoor map renderer")
+    (description
+     "This package provides facilities for rendering OpenStreetMap
+multi-floor indoor maps.")
+    (license license:lgpl2.0+)))
+
 (define-public kpmcore
   (package
     (name "kpmcore")