summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 14:32:59 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:19 -0500
commit93c1fdd3032446f3933fba5c6bae367a191dd1d4 (patch)
treeaf7601a97faf6a54286d6d1a6900b21163300c78 /gnu
parent1631a0f794257c2b5a92f7ef405b7d1ce4889da7 (diff)
downloadguix-93c1fdd3032446f3933fba5c6bae367a191dd1d4.tar.gz
gnu: ghc-zip-archive: Update to 0.4.1.
* gnu/packages/haskell-xyz.scm (ghc-zip-archive): Update to 0.4.1.
[arguments]: Add a phase that sets up the environment for the tests.
[native-inputs]: Add 'which'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index ba512debd2..e6c3275f86 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11904,7 +11904,7 @@ documents.")
 (define-public ghc-zip-archive
   (package
     (name "ghc-zip-archive")
-    (version "0.3.3")
+    (version "0.4.1")
     (source
      (origin
        (method url-fetch)
@@ -11914,15 +11914,26 @@ documents.")
              ".tar.gz"))
        (sha256
         (base32
-         "0kf8xyac168bng8a0za2jwrbss7a4ralvci9g54hnvl0gkkxx2lq"))))
+         "1cdix5mnxrbs7b2kivhdydhfzgxidd9dqlw71mdw5p21cabwkmf5"))))
     (build-system haskell-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'set-PATH-for-tests
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((unzip (assoc-ref inputs "unzip"))
+                   (which (assoc-ref inputs "which"))
+                   (path (getenv "PATH")))
+               (setenv "PATH" (string-append unzip "/bin:" which "/bin:" path))
+               #t))))))
     (inputs
      `(("ghc-digest" ,ghc-digest)
        ("ghc-temporary" ,ghc-temporary)
        ("ghc-zlib" ,ghc-zlib)))
     (native-inputs
      `(("ghc-hunit" ,ghc-hunit)
-       ("unzip" ,unzip)))
+       ("unzip" ,unzip)
+       ("which" ,which)))
     (home-page "https://hackage.haskell.org/package/zip-archive")
     (synopsis "Zip archive library for Haskell")
     (description "The zip-archive library provides functions for creating,