summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-11-03 12:30:44 -0500
committerChristopher Baines <mail@cbaines.net>2022-11-03 18:44:59 +0100
commit9560932ce04bfecdfefc5fdb8699fa1f64887286 (patch)
tree0190a829ee910f7ac8a75c89230d30cadcbe6f1c /gnu
parent06d02b7a2c059cafff9ea53da8208be6193f2335 (diff)
downloadguix-9560932ce04bfecdfefc5fdb8699fa1f64887286.tar.gz
gnu: Add python-eris.
* gnu/packages/python-xyz.scm (python-eris): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 00cc7fe01e..19bbea7d42 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31233,6 +31233,25 @@ platform using the ActivityPub protocol.")
 and abstract ELF, PE and MachO formats.")
     (license license:asl2.0)))
 
+(define-public python-eris
+  (package
+    (name "python-eris")
+    (version "0.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "eris" version))
+              (sha256
+               (base32
+                "16wbmahmfzdzrsjbn8jzi79vhghrzvvlcgnym20q0v3p3i4x47pq"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pycryptodome))
+    (home-page "https://codeberg.org/eris/python-eris")
+    (synopsis "Python implementation of ERIS")
+    (description
+"Python implementation of the @acronym{ERIS, Encoding for Robust Immutable
+Storage}.")
+    (license license:lgpl3+)))
+
 (define-public shrinkwrap
   (package
     (name "shrinkwrap")