summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-21 15:08:27 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:22:59 +0100
commitad004a2f663a1af8c9b7a3252e18525d5ee80a44 (patch)
tree790910b610b6158e9173f9aa94b14d426311bc41 /gnu
parentee6e69a554073b0b55ffbbd9ad2e451ae234c5f2 (diff)
downloadguix-ad004a2f663a1af8c9b7a3252e18525d5ee80a44.tar.gz
gnu: postgresql: Add 14.1.
* gnu/packages/databases.scm (postgresql-14): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 2dec250a5e..6ca1f814de 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1154,17 +1154,17 @@ and high-availability (HA).")
     (license license:gpl2)))                  ;'COPYING' says "version 2" only
 
 ;; Don't forget to update the other postgresql packages when upgrading this one.
-(define-public postgresql-13
+(define-public postgresql-14
   (package
     (name "postgresql")
-    (version "13.4")
+    (version "14.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://ftp.postgresql.org/pub/source/v"
                                   version "/postgresql-" version ".tar.bz2"))
               (sha256
                (base32
-                "1kf0gcsrl5n25rjlvkh87aywmn28kbwvakm5c7j1qpr4j01y34za"))
+                "07x45iycqpps0qh3ingc09jgn9rpnmc3gixx0qprhf5flwg10g2d"))
               (patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
     (build-system gnu-build-system)
     (arguments
@@ -1211,6 +1211,18 @@ TIMESTAMP.  It also supports storage of binary large objects, including
 pictures, sounds, or video.")
     (license (license:x11-style "file://COPYRIGHT"))))
 
+(define-public postgresql-13
+  (package
+    (inherit postgresql-14)
+    (version "13.4")
+    (source (origin
+              (inherit (package-source postgresql-14))
+              (uri (string-append "https://ftp.postgresql.org/pub/source/v"
+                                  version "/postgresql-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1kf0gcsrl5n25rjlvkh87aywmn28kbwvakm5c7j1qpr4j01y34za"))))))
+
 (define-public postgresql-11
   (package
     (inherit postgresql-13)