summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-05 21:37:06 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-05 22:42:25 +0100
commitc19f968cbd189ae4b7c2d0dba1c2040f1c560c2c (patch)
tree987fea967666a7477e858de915464d3318986b11 /gnu
parenta9d426c492e7834bf658ab598fea3be32608839d (diff)
downloadguix-c19f968cbd189ae4b7c2d0dba1c2040f1c560c2c.tar.gz
gnu: librsvg@2.40: Depend on the default Pango version.
This avoids conflicts where, say, gtk+ would pull pango@1.44 whereas
mate-control-center would additionally pull pango@1.42 via librsvg@2.40
on i686-linux.

* gnu/packages/gnome.scm (librsvg-2.40)[arguments]: In
'remove-failing-tests' phase, remove two additional tests.
[inputs]: Change PANGO-1.42 to PANGO.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 04632ad46c..df6f2944e9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3675,16 +3675,19 @@ diagrams.")
                            ;; This test fails on armhf:
                            "svg1.1/masking-mask-01-b.svg"
                            ;; This test fails on aarch64:
-                           "bugs/777834-empty-text-children.svg")))
-             #t)))))
+                           "bugs/777834-empty-text-children.svg"
+
+                           ;; These two tests fail due to slightly different
+                           ;; text rendering (different kerning or similar),
+                           ;; nothing alarming.
+                           "bugs/340047.svg"
+                           "bugs/749415.svg"))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("glib" ,glib "bin")                               ; glib-mkenums, etc.
        ("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
     (inputs
-     `(;; XXX: 1.44 causes some test failures, so we stick with 1.42 for
-       ;; this ancient version of librsvg.
-       ("pango" ,pango-1.42)
+     `(("pango" ,pango)
        ("libcroco" ,libcroco)
        ("bzip2" ,bzip2)
        ("libgsf" ,libgsf)