summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRostislav Svoboda <rostislav.svoboda@gmail.com>2023-03-24 09:25:57 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-24 09:26:19 +0100
commitced76608d68a5832b94dcf7aa18df1115a4c06c0 (patch)
tree9cc6b6b83c1d60b86ab37896fb24b74efb033497 /gnu
parent5bed6d6846b0ae1e0cb8f6f52ee4bbf8efe72454 (diff)
downloadguix-ced76608d68a5832b94dcf7aa18df1115a4c06c0.tar.gz
gnu: Add emacs-column-enforce-mode.
* gnu/packages/emacs-xyz.scm (emacs-column-enforce-mode): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 18d4623688..6e4069cb7c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26918,6 +26918,31 @@ scratch, and you think the Spacemacs theme looks good.
           (base32 "11lwckqcgzsahrkkm5wk1ph4kc7d4yz05r7251g8c9f0q6vdj9dp"))
          (file-name (git-file-name name version)))))))
 
+(define-public emacs-column-enforce-mode
+  (let ((commit "14a7622f2268890e33536ccd29510024d51ee96f")
+        (revision "1"))
+    (package
+      (name "emacs-column-enforce-mode")
+      (version (git-version "1.0.4" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url
+                       "https://github.com/jordonbiondo/column-enforce-mode")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1vxra5vk78yns2sw89m41bggczqg1akq6xvzfs9kylhkg5yz3g7g"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/jordonbiondo/column-enforce-mode")
+      (synopsis "Highlight text that extends beyond a certain column")
+      (description
+       "Column Enforce mode highlights text that extends beyond a certain
+column.  It can be used to enforce 80 column rule.  It can also be configured
+for any @var{N}-column rule.")
+      (license license:gpl3+))))
+
 (define-public emacs-column-marker
   (package
     (name "emacs-column-marker")