summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2021-12-30 15:47:22 +0100
committerJelle Licht <jlicht@fsfe.org>2021-12-30 15:47:22 +0100
commitd91a5cf1ef921a45a2303de87659723b0226d6f9 (patch)
tree5ac21031635d4ff9e33356f4a5a078ad660d3da4 /gnu
parent1cfb8be3a1df432fbb78a3fcfdc0a0b4700059da (diff)
downloadguix-d91a5cf1ef921a45a2303de87659723b0226d6f9.tar.gz
gnu: Add python-nb-clean.
* gnu/packages/python-xyz.scm (python-nb-clean): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3a9e35aacf..02aa58dcf0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11855,6 +11855,27 @@ drafts 04, 06 and 07.")
 Jupyter Notebook format and Python APIs for working with notebooks.")
     (license license:bsd-3)))
 
+(define-public python-nb-clean
+  (package
+    (name "python-nb-clean")
+    (version "2.1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "nb-clean" version))
+        (sha256
+          (base32 "01qvk9n7rx15dhc23m8bj9bw5wdyxh6y18c5fm8hllmrd3ndsx14"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-nbformat))
+    (home-page "https://github.com/srstevenson/nb-clean")
+    (synopsis "Clean Jupyter notebooks for versioning")
+    (description "This package cleans Jupyter notebooks of cell execution
+counts, metadata, outputs, and empty cells, preparing them for committing to
+version control.  It provides a Git filter to automatically clean notebooks
+before they're staged, and can also be used with other version control
+systems, as a command line tool, and as a Python library.")
+    (license license:isc)))
+
 (define-public python-bleach
   (package
     (name "python-bleach")