summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-05-16 18:08:44 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-05-17 22:55:33 -0400
commite7e2b1c10b9a779ac7938909dbfafbc739740363 (patch)
treedbf18b8cc5d603f9c9d54c8211848397aea47177 /gnu
parentc2b183e13d7bcd36cc62253add436eb2946abe4e (diff)
downloadguix-e7e2b1c10b9a779ac7938909dbfafbc739740363.tar.gz
gnu: Add python-tappy.
* gnu/packages/python-check.scm (python-tappy): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f0b454eec9..1206dda5c4 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -48,6 +48,25 @@
   #:use-module (guix download)
   #:use-module (guix build-system python))
 
+(define-public python-tappy
+  (package
+    (name "python-tappy")
+    (version "3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "tap.py" version))
+       (sha256
+        (base32
+         "0w4w6pqjkv54j7rv6vdrpfxa72c5516bnlhpcqr3vrb4zpmyxvpm"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/python-tap/tappy")
+    (synopsis "Tools for Test Anything Protocol")
+    (description "Tappy is a set of tools for working with the Test Anything
+Protocol (TAP) in Python.  TAP is a line based test protocol for recording test
+data in a standard way.")
+    (license license:bsd-3)))
+
 (define-public python-pytest-click
   (package
     (name "python-pytest-click")