summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAdam Faiz <adam.faiz@disroot.org>2023-04-22 10:55:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-22 11:55:50 +0200
commitf07d5c38c55bf561b2f3948096a6a050fd291fb8 (patch)
treea5d2e50a80cfbccfcf008203f221b0fb753469d9 /gnu
parent9ceb0164c25d9e9e47eac7c65c307ebd2824467f (diff)
downloadguix-f07d5c38c55bf561b2f3948096a6a050fd291fb8.tar.gz
gnu: Add dataparksearch.
* gnu/packages/search.scm (dataparksearch): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/search.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index c8c3ff45d0..71609a21fa 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -12,6 +12,7 @@
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2023 Adam Faiz <adam.faiz@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -40,6 +41,7 @@
   #:use-module (guix build-system python)
   #:use-module (guix build-system meson)
   #:use-module (gnu packages)
+  #:use-module (gnu packages adns)
   #:use-module (gnu packages aspell)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
@@ -51,6 +53,7 @@
   #:use-module (gnu packages gawk)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnunet)
   #:use-module (gnu packages groff)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages icu4c)
@@ -67,6 +70,7 @@
   #:use-module (gnu packages qt)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages time)
+  #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xml)
@@ -328,6 +332,61 @@ accounting for new lines and paragraph changes.  It also has robust support
 for parsing HTML files.")
     (license license:gpl3+)))
 
+(define-public dataparksearch
+  (let ((commit "8efa28f31ce1273c0556fd5c7e06abe955197a69")
+        (revision "0"))
+    (package
+      (name "dataparksearch")
+      (version (git-version "4.54" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/Maxime2/dataparksearch")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "01z7s3ws5px2p9brzrq9j41jbdh1cvj8n8y3ghx45gfv1n319ipg"))
+                (modules '((guix build utils)))
+                (snippet
+                 #~(for-each delete-file '("config.sub"
+                                           "config.guess"
+                                           "configure"
+                                           "Makefile.in"
+                                           "missing"
+                                           "depcomp"
+                                           "ltmain.sh"
+                                           "compile")))
+                (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (arguments
+       (list
+        #:configure-flags
+        #~(list "--with-extra-charsets=all"
+                (string-append "--with-aspell=" #$(this-package-input "aspell"))
+                (string-append "--with-pgsql="
+                               #$(this-package-input "postgresql")))
+        #:make-flags
+        #~(list "DPS_TEST_DBADDR=postgresql://localhost/tmp/postgresql/")))
+      (native-inputs
+       (list autoconf automake libtool openjade pkg-config))
+      (inputs
+       (list aspell
+             c-ares
+             libextractor
+             mbedtls-apache
+             postgresql
+             zlib))
+      (synopsis "Feature rich search engine")
+      (description
+       "Dataparksearch is a full featured web search engine.
+It has support for HTTP, HTTPS, ftp (passive mode), NNTP and news URL schemes,
+and other URL schemes with external parsers.  It can tweak URLs with session
+IDs and other weird formats, including some JavaScript link decoding.  Options
+to query with all words, all words near to each others, any words, or boolean
+queries.  A subset of VQL (Verity Query Language) is supported.")
+      (home-page "https://www.dataparksearch.org/")
+      (license license:gpl2+))))
+
 (define-public fsearch
   (package
     (name "fsearch")