summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-01-17 18:30:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-20 10:44:27 +0100
commitf145afd16f1a20c56ebd937b407cb4ad8c32f0e5 (patch)
tree7a0a8aa811666bf0b1b0beacb2b26bf41e8ce41d /gnu
parenta7f1a1c0f0c1fbbac87c2a1b8736ebca8cca6e09 (diff)
downloadguix-f145afd16f1a20c56ebd937b407cb4ad8c32f0e5.tar.gz
gnu: Add r-scistreer.
* gnu/packages/bioconductor.scm (r-scistreer): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 93c6165b62..6d16a99c36 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2017, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2018, 2019, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019, 2020, 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2019, 2020, 2021, 2022, 2023 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2020 Peter Lo <peterloleungyau@gmail.com>
 ;;; Copyright © 2020, 2021, 2022 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
@@ -7397,6 +7397,43 @@ includes methods formerly found in the scran package, and the new fast and
 comprehensive scDblFinder method.")
     (license license:gpl3)))
 
+;; This is a CRAN package, but it depends on packages from Bioconductor.
+(define-public r-scistreer
+  (package
+    (name "r-scistreer")
+    (version "1.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "scistreer" version))
+              (sha256
+               (base32
+                "0cdp26ngfp5rxa21nqnj6j2098f6996368g4msb3shh7n75np4s9"))))
+    (properties `((upstream-name . "scistreer")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-ape
+                             r-dplyr
+                             r-ggplot2
+                             r-ggtree
+                             r-igraph
+                             r-paralleldist
+                             r-patchwork
+                             r-phangorn
+                             r-rcpp
+                             r-rcpparmadillo
+                             r-rcppparallel
+                             r-reshape2
+                             r-rhpcblasctl
+                             r-stringr
+                             r-tidygraph))
+    (home-page "https://github.com/kharchenkolab/scistreer")
+    (synopsis "Maximum-likelihood perfect phylogeny Inference at scale")
+    (description
+     "This package provides fast maximum-likelihood phylogeny inference from
+noisy single-cell data using the ScisTree algorithm proposed by
+@code{doi.org/10.1093/bioinformatics/btz676, Yufeng Wu (2019)}.  It makes the
+method applicable to massive single-cell datasets (>10,000 cells).")
+    (license license:gpl3)))
+
 (define-public r-scmap
   (package
     (name "r-scmap")