summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-09-22 19:00:08 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-09-22 19:07:57 +0200
commit0193812a3d44cf982f868e2171386204fa7dbda6 (patch)
treec1fb530d6ef217b5029fe1ae4cb6fbed0302d428 /gnu
parent12ae25db458a09d657e1b3410996b6bfb99ee5c4 (diff)
downloadguix-0193812a3d44cf982f868e2171386204fa7dbda6.tar.gz
gnu: bitcoin-core: Build with modular Qt.
* gnu/packages/finance.scm (bitcoin-core)[native-inputs]: Add QTTOOLS.
[inputs]: Remove QT.  Add QTBASE.
[arguments]: Specify paths to "lrelease" and "lupdate" in #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 823eabf5a8..9e346a6625 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -70,7 +70,8 @@
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python" ,python) ; for the tests
-       ("util-linux" ,util-linux))) ; provides the hexdump command for tests
+       ("util-linux" ,util-linux)   ; provides the hexdump command for tests
+       ("qttools" ,qttools)))
     (inputs
      `(("bdb" ,bdb-5.3) ; with 6.2.23, there is an error: ambiguous overload
        ("boost" ,boost)
@@ -78,8 +79,7 @@
        ("miniupnpc" ,miniupnpc)
        ("openssl" ,openssl)
        ("protobuf" ,protobuf)
-       ;; TODO Build with the modular Qt.
-       ("qt" ,qt)))
+       ("qtbase" ,qtbase)))
     (arguments
      `(#:configure-flags
         (list
@@ -87,7 +87,16 @@
           "--with-incompatible-bdb"
           ;; Boost is not found unless specified manually.
           (string-append "--with-boost="
-                         (assoc-ref %build-inputs "boost")))
+                         (assoc-ref %build-inputs "boost"))
+          ;; XXX: The configure script looks up Qt paths by
+          ;; `pkg-config --variable=host_bins Qt5Core`, which fails to pick
+          ;; up executables residing in 'qttools', so we specify them here.
+          (string-append "ac_cv_path_LRELEASE="
+                         (assoc-ref %build-inputs "qttools")
+                         "/bin/lrelease")
+          (string-append "ac_cv_path_LUPDATE="
+                         (assoc-ref %build-inputs "qttools")
+                         "/bin/lupdate"))
        #:phases
         (modify-phases %standard-phases
           (add-before 'check 'set-home