summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-28 16:03:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-28 21:24:12 +0200
commit511bfafa14e90304b1c9b82dad7321daa1668e32 (patch)
tree8335d419ccf90e48d13b507b8ecf788b8efeb812 /gnu
parent33de9ee42fb53b47a21409aaa1dd1feca61d6b37 (diff)
downloadguix-511bfafa14e90304b1c9b82dad7321daa1668e32.tar.gz
gnu: straw-viewer: Comment out .desktop installation.
This will only make sense when the GTK version is built.

* gnu/packages/video.scm (straw-viewer)[arguments]: Comment out
‘install-desktop’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e63f2341c9..e3bb447fa0 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -577,15 +577,15 @@ H.264 (MPEG-4 AVC) video streams.")
                 (format #f "'~a/bin/xdg-open'"
                         (assoc-ref inputs "xdg-utils"))))
              #t))
-         (add-after 'install 'install-desktop
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (sharedir (string-append out "/share")))
-               (install-file "share/gtk-straw-viewer.desktop"
-                             (string-append sharedir "/applications"))
-               (install-file "share/icons/gtk-straw-viewer.png"
-                             (string-append sharedir "/pixmaps"))
-               #t)))
+         ;; (add-after 'install 'install-desktop
+         ;;   (lambda* (#:key outputs #:allow-other-keys)
+         ;;     (let* ((out (assoc-ref outputs "out"))
+         ;;            (sharedir (string-append out "/share")))
+         ;;       (install-file "share/gtk-straw-viewer.desktop"
+         ;;                     (string-append sharedir "/applications"))
+         ;;       (install-file "share/icons/gtk-straw-viewer.png"
+         ;;                     (string-append sharedir "/pixmaps"))
+         ;;       #t)))
          (add-after 'install 'wrap-program
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))