summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-05 15:19:38 -0600
committerEric Bavier <bavier@member.fsf.org>2015-03-06 08:13:26 -0600
commit90ae6151cf00075e288f9125543124ebbc1fe9de (patch)
tree0dd7720d4daae6ca4d4ae6a86f84cfbf8650c3b5 /gnu
parenta77ed67def78af17d54aa9cac998384e663f08a9 (diff)
downloadguix-90ae6151cf00075e288f9125543124ebbc1fe9de.tar.gz
gnu: Add Try-Tiny.
* gnu/packages/perl.scm (perl-try-tiny): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f79f568476..523dcdfa9c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -640,6 +640,26 @@ a minimum of effort.")
     ;; "Under the same license as Perl itself"
     (license (package-license perl))))
 
+(define-public perl-try-tiny
+  (package
+    (name "perl-try-tiny")
+    (version "0.22")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/D/DO/DOY/"
+                           "Try-Tiny-" version ".tar.gz"))
+       (sha256
+        (base32
+         "068vdbpacfawc3lkfs0b82xxl27h3l0gj14iada3vlwk8rps9yv0"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Try-Tiny")
+    (synopsis "Minimal try/catch with proper preservation of $@")
+    (description "This module provides bare bones try/catch/finally statements
+that are designed to minimize common mistakes with eval blocks, and nothing
+else.")
+    (license x11)))
+
 
 ;;; Some packaged modules need versions of core modules that are newer than
 ;;; those in our perl 5.16.1.