summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 17:01:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:03 -0400
commit7cd3a88f27b4d90b18cba1dd1fd1e1b9cc4c8f8e (patch)
treebc8bdec66fd07045a79288fe94eba6237fdc520a /gnu
parent4d7bb37981d5d1e639cbd7837cddc76c45271de2 (diff)
downloadguix-7cd3a88f27b4d90b18cba1dd1fd1e1b9cc4c8f8e.tar.gz
gnu: Remove python2-pysqlite.
* gnu/packages/databases.scm (python2-pysqlite): Delete variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 7be109a6bc..cd5045ed12 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3302,30 +3302,6 @@ local Cassandra clusters. It creates, launches and removes Cassandra clusters
 on localhost.")
     (license license:asl2.0)))
 
-(define-public python2-pysqlite
-  (package
-    (name "python2-pysqlite")
-    (version "2.8.3")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (pypi-uri "pysqlite" version))
-      (sha256
-       (base32
-        "1424gwq9sil2ffmnizk60q36vydkv8rxs6m7xs987kz8cdc37lqp"))))
-    (build-system python-build-system)
-    (inputs
-     (list sqlite))
-    (arguments
-     `(#:python ,python-2 ; incompatible with Python 3
-       #:tests? #f)) ; no test target
-    (home-page "https://github.com/ghaering/pysqlite")
-    (synopsis "SQLite bindings for Python")
-    (description
-     "Pysqlite provides SQLite bindings for Python that comply to the
-Database API 2.0T.")
-    (license license:zlib)))
-
 (define-public python-sqlalchemy
   (package
     (name "python-sqlalchemy")