summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-06-14 13:58:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-06-14 15:32:32 -0400
commit0e5539148244077215a984af9347a739c65e7ccb (patch)
treec60797c9dde13ab13fc6d21210ac6ad58688ed31 /gnu
parent87cf2a859d62aa24dda8ced7b04f54a3ee9c466c (diff)
downloadguix-0e5539148244077215a984af9347a739c65e7ccb.tar.gz
gnu: scintilla: Use string-delete to compute source URL.
* gnu/packages/text-editors.scm (scintilla) [source]: Use string-delete
instead of string-split and string-append.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/text-editors.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index b23c5ba2be..c4c2893009 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -1006,8 +1006,8 @@ The basic features of Text Pieces are:
     (source
      (origin
        (method url-fetch)
-       (uri (let ((v (apply string-append (string-split version #\.))))
-              (string-append "https://www.scintilla.org/scintilla" v ".tgz")))
+       (uri (string-append "https://www.scintilla.org/scintilla"
+                           (string-delete #\. version) ".tgz"))
        (sha256
         (base32 "0inbhzqdikisvnbdzn8153p1apbghxjzkkzji9i8zsdpyapb209z"))))
     (build-system gnu-build-system)
@@ -1030,10 +1030,8 @@ The basic features of Text Pieces are:
                           (find-files "bin/" "\\.so$"))
                 (for-each (lambda (f) (install-file f inc))
                           (find-files "include/" "."))))))))
-    (native-inputs
-     (list pkg-config python-wrapper))
-    (inputs
-     (list gtk+))
+    (native-inputs (list pkg-config python-wrapper))
+    (inputs (list gtk+))
     (home-page "https://www.scintilla.org/")
     (synopsis "Code editor for GTK+")
     (description "Scintilla is a source code editing component for