summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-02 18:32:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-02 18:32:10 +0100
commit1123d25830203f9bbddbd4c4c72d974976e0c5b8 (patch)
tree62f3e8458424fe933ad6dd3846fd563c951c1399 /gnu
parentf28f5be11d6849fcd2852913731dd750d18fd123 (diff)
downloadguix-1123d25830203f9bbddbd4c4c72d974976e0c5b8.tar.gz
gnu: ribodiff: Disable broken test.
* gnu/packages/bioinformatics.scm (ribodiff)[arguments]: Add build phase
'disable-plot-test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 443c405971..72de84f1e6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -829,6 +829,11 @@ provides the Ribotaper pipeline.")
      `(#:python ,python-2
        #:phases
        (modify-phases %standard-phases
+         ;; This test fails because of the matplotlib plotting backend.
+         (add-after 'unpack 'disable-plot-test
+           (lambda _
+             (substitute* "src/ribodiff/functional_test_te.py"
+               (("pl\\.make_plots\\(data, opts\\)") "#"))))
          ;; Generate an installable executable script wrapper.
          (add-after 'unpack 'patch-setup.py
            (lambda _